Actualizando a WordPress 1.5

Bueno, el trabajo no está hecho del todo, pero la cosa va funcionando… La verdad es que la 1.5 es una mejora, pero algunos avisos para navegantes:

  • Si tu CSS de WordPress usa imágenes, y las llamabas con un path relativo, dado que ahora viven en un lugar diferente, dejarán de funcionar. No es difícil de arreglar, pero mejor tenerlo en cuenta. De momento, eso significa que Otro blog más se quedará con el estilo Kubrick al menos hasta mañana (y conociéndome, más).
  • La estructura de WP 1.5, con Kubrik, es mucho más modular: hay un archivo para la cabecera, otro para el pie, y el contenido sale de un sitio si se trata de un archivo (mensual o de categorías) y de otro si se trata de una sola entrada. Eso está muy bien porque da mucho juego, pero también significa que hay que aprender dónde están las cosas. No es problema si tienes una míonima idea de PHP (y la mía es bastante mínima), pero hay que tenerlo en cuenta. Me ha costado un ratillo decidir que el Javascript para Nedstat lo pongo en el pie, el de Phlogger en la cabecera, y que hay que poner el código de los anuncios de Google en otro… Entre una cosa y otra, he estado una hora sin estadísticas ni publicidad.
  • La plantilla Kubrik, por defecto, en las páginas de archivo sólo te coloca los inicios de cada entrada (y se come, por ejemplo, las imágenes). No es difícil de cambiar: allí donde pone the_excerpt() hay que poner the_content('Leer el resto de la entrada »'). Pero el susto que me he llevado…
  • Y una cosilla más de la plantilla Kubrik: me gusta mucho y es muy legible, pero maltrata un poco a los usuarios de Explorer: la tipografía de la barra de la derecha es minúscula con IE6, y mucho más legible con Firefox. A pesar de que me gusta mucho más Firefox, no me han hecho nada los usuarios de Explorer…

3 opiniones en “Actualizando a WordPress 1.5”

  1. Buenas, acabo de llegar al mundo del wordpress, (vengo del phpnuke), me instal la version 1.2 y seguidamente sin darme tiempo a trastear un poquillo, apareci la 1.5 y la traduccin en espaol, pues nada, instal esta nueva version, pero…. me encuentro que ahora el registro de usuarios obliga a la confirmacion de estos por correo electronico, mi pregunta de nefito es; existe algun plugin o manera de evitar que tenga que cargar un servidor smtp, y que el registro sea como en la version 1.2 que no era necesario?
    Saludos, y larga vida al WP

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.